Low Capacity in SIN and AMS regions

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 29, 2026 - 16:01 UTC

Update

We've freed up additional room in the SIN and AMS regions and are monitoring capacity.
Posted Mar 29, 2026 - 15:35 UTC

Monitoring

We've freed up additional room in the SIN and AMS regions and are monitoring capacity.
Posted Mar 29, 2026 - 15:33 UTC

Update

We are currently investigating capacity issues in SIN and AMS regions that are affecting:
- Machine Create and Start events
- Deployments, due to affected, degraded Remote Builders
- Sprite startup from cold state
Posted Mar 29, 2026 - 15:19 UTC

Update

This may also affect:
- Remote builders in AMS and SIN regions, which could currently be experiencing degraded performance or failures.
- Sprites starting from a cold state, which may experience failures in starting
Posted Mar 29, 2026 - 15:13 UTC

Identified

We are currently investigating elevated errors when creating and starting machines in the SIN and AMS regions. Choosing other regions to create or deploy may help in the meantime
Posted Mar 29, 2026 - 15:00 UTC
This incident affected: Regional Availability (AMS - Amsterdam, Netherlands, SIN - Singapore) and Sprites.