Issues with flyctl ssh console and Machines OIDC

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 18:43 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 18:35 UTC

Investigating

We're currently investigating an issue affecting flyctl ssh console functionality and machines' OIDC tokens.
Posted Jun 01, 2026 - 18:33 UTC
This incident affected: Machines API.