fly ssh console returns error 500

Incident Report for Fly.io

Resolved

This issue has been resolved, fly ssh console invocations are now working correctly.
Posted May 15, 2026 - 17:24 UTC

Monitoring

We've deployed a fix and are monitoring as error rates normalize. `fly ssh console` should be working now.
Posted May 15, 2026 - 16:40 UTC

Identified

A problem with our vault used to issue temporary certificates for SSH sessions is causing calls to `fly ssh console` and `fly console` to return error 500.

Our team has identified the cause and is deploying a fix.
Posted May 15, 2026 - 16:29 UTC