Egress IP issues in SIN and NRT

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 14:03 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 30, 2026 - 13:49 UTC

Identified

We are aware of egress IP issues in SIN and NRT and are working on a fix. Some machines in SIN and NRT using egress IPs may temporarily lose connectivity or otherwise see degraded performance.
Posted Jun 30, 2026 - 13:45 UTC
This incident affected: Regional Availability (NRT - Tokyo, Japan, SIN - Singapore).