Machines errors in JNB region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 12:29 UTC

Identified

A bad deploy of an internal service in JNB region may cause Machines API requests for JNB region machines to fail. At this time, it may not be possible to create or update machines in JNB region, but apps continue to run. The deploy is being reverted.
Posted Jan 19, 2026 - 12:17 UTC
This incident affected: Regional Availability (JNB - Johannesburg, South Africa).