Intermittent registry errors

Incident Report for Fly.io

Resolved

This issue has been resolved.

Any users still encountering errors deploying, please check and make sure your flyctl version is >=v0.3.180, and update with `fly version update` if not.
Posted Oct 08, 2025 - 00:52 UTC

Update

We have seen a strong decrease in errors for most users. We are seeing some 401 errors still for users using old versions of flyctl.

Users encountering a 401 error and using a version under v0.3.180, should run `flyctl version update` to update to the latest flyctl version.
Posted Oct 07, 2025 - 21:35 UTC

Monitoring

A fix has been deployed and we are monitoring the results. We are seeing a decrease in 401 / 499 errors when deploying.

This issue primarily impacted users deploying apps via the Fly Dashboard, deploys using flyctl versions lower than v0.3.180, and deploys involving building very large images.
Posted Oct 07, 2025 - 20:49 UTC

Investigating

Users may notice intermittent 4XX errors while pushing to Fly registry.
Posted Oct 07, 2025 - 11:57 UTC
This incident affected: Deployments.