TLS certificate issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 16:27 UTC

Investigating

We are investigating an issue with the Vault server that stores TLS certificates. Provisioning new TLS certificates may fail, and connecting to domains whose existing certificate has not yet been cached may fail.
Posted Oct 24, 2025 - 16:13 UTC
This incident affected: SSL/TLS Certificate Provisioning.