Increased network latency in North America

Incident Report for Fly.io

Monitoring

Our upstream paths have been fixed. We are monitoring the results.
Posted Jun 11, 2026 - 10:09 UTC

Update

We are working with our upstream network provider to address periodic loss of connectivity over transit in ord
Posted Jun 11, 2026 - 09:35 UTC

Identified

We are seeing a recurrence of elevated latency across some hosts in ORD impacting the MPG control plane and a subset of clusters there. We are working to address this.
Posted Jun 11, 2026 - 07:58 UTC

Update

The network between our regions has been performing well for the majority of traffic. We're still continuing to monitor a few impacted routes in North America that may be seeing elevated latency and packet loss.
Posted Jun 11, 2026 - 05:24 UTC

Update

Impacted NA backbones have been sidestepped where possible, and we're continuing to monitor network health.
Posted Jun 11, 2026 - 03:30 UTC

Monitoring

Managed Postgres in ORD has returned to normal operation.

We continue to see slightly elevated latencies and loss over transits in North America. We are working with our upstream network providers to improve performance.
Posted Jun 11, 2026 - 01:59 UTC

Investigating

We are investigating elevated network instability across some hosts in ORD. Apps and managed postgres clusters on impacted hosts may see elevated latency or networking errors at this time.
Posted Jun 11, 2026 - 01:16 UTC
This incident affects: Managed Postgres (Management Plane - ORD) and Regional Availability (ORD - Chicago, Illinois (US)).