MPG cluster issues in ORD

Incident Report for Fly.io

Resolved

This incident has been resolved and all MPG clusters in ORD are operating as expected.

During this incident a small number of clusters in ORD would have seen degraded or failing connections when using the PGBouncer connection pooler URL to connect to their database.
Posted Aug 23, 2025 - 13:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 23, 2025 - 12:33 UTC

Investigating

We are currently investigating a host issue resulting in a small number of MPG clusters in ORD to be in degraded status. If you're having trouble connecting to your database, please get in touch via the support portal.
Posted Aug 23, 2025 - 09:36 UTC
This incident affected: Managed Postgres (Management Plane - ORD).