Network instability in IAD (Ashburn, Virginia) region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 07:20 UTC

Monitoring

A mitigation has been implemented and we are monitoring the results. There may continue to be some packet loss and closed connections until the emergency maintenance in IAD scheduled for 2025-12-08 at 5:00 AM UTC is completed.
Posted Dec 08, 2025 - 01:18 UTC

Investigating

We are investigating network congestion in the IAD region that is causing dropped packets and closed connections. This impacts both user applications and Managed Postgres clusters, as well as some API operations.
Posted Dec 08, 2025 - 00:42 UTC