Depot builders failing with internal error

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 00:29 UTC

Monitoring

A fix has been implemented on Depot side. https://status.depot.dev/cm6zolsn40009f2dj5ss7lrd7
Posted Feb 11, 2025 - 00:10 UTC

Identified

The Depot service is currently degraded due to a database outage. We're continuing to monitor for recovery. Customers can also follow the Depot status page at https://status.depot.dev/ for updates.

Customers that need to deploy can use legacy Fly.io hosted builders with `fly deploy --depot=false`
Posted Feb 10, 2025 - 23:52 UTC

Investigating

We are investigating failures when trying to build using the default Depot builders.

The recommended workaround is to use `--depot=false` with `fly deploy`.

The error from Depot builders is `Error: failed to fetch an image or build from source: error building: input:3: ensureDepotRemoteBuilder {"code"=>"internal", "message"=>"internal error"}`
Posted Feb 10, 2025 - 23:21 UTC
This incident affected: Remote Builds.