Network issues in SIN region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 21, 2026 - 19:59 UTC

Monitoring

Our upstream provider has implemented a fix and all apps and Managed Postgres clusters are now reachable.

For the time being, ingress traffic is being re-routed to other regions, so users around the Singapore area may experience higher latency.
Posted May 21, 2026 - 18:45 UTC

Investigating

We are investigating network issues in the Singapore region. Apps may experience higher latency or be unreachable at this time. Some Managed Postgres clusters may be unreachable.
Posted May 21, 2026 - 18:30 UTC
This incident affected: Managed Postgres (Management Plane - SIN) and Regional Availability (SIN - Singapore).