Managed Postgres v2 control plane issues in iad

Incident Report for Fly.io

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2026 - 17:26 UTC

Investigating

We are investigating an issue with the control plane for Managed Postgres v2 in the IAD region. Creating new v2 clusters in the IAD region may fail at this time. Existing clusters continue to run, but may experience lagging backups.
Posted Aug 01, 2026 - 17:01 UTC
This incident affects: Managed Postgres (Management Plane - IAD).