Machines API degraded performance

Incident Report for Fly.io

Resolved

We identified the problem and deployed a fix.
Posted May 16, 2025 - 04:31 UTC

Investigating

We're investigating degraded performance with the Machines API metadata update endpoint.
Posted May 16, 2025 - 02:51 UTC