Network issues in Europe

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Sep 22, 2025 - 18:47 UTC

Monitoring

We have shifted routes to alternative transit providers and are monitoring the results.
Posted Sep 22, 2025 - 17:05 UTC

Investigating

We are investigating a loss of connectivity from our Europe regions to a US-based management cluster. You may experience 500s on the Machines API `/v1/tokens/oidc` endpoint, as well as network issues connecting to Fly Machines or external services hosted in the Boston region.
Posted Sep 22, 2025 - 16:56 UTC
This incident affected: Regional Availability (AMS - Amsterdam, Netherlands, CDG - Paris, France, FRA - Frankfurt, Germany, JNB - Johannesburg, South Africa, LHR - London, United Kingdom).