Failing to pull image
Incident Report for Fly.io
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 19:07 UTC
Update
This issue has been mitigated, but we're still working on a more permanent fix.
Posted Sep 05, 2023 - 13:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2023 - 22:19 UTC
Update
We have a registry that only keeps storage in the iad region, which we think will work around the issue you are seeing. Try it out with:

FLY_REGISTRY_HOST=registry-iad.fly.io fly deploy

Use this if you are doing docker push directly to the registry:

FLY_REGISTRY_HOST=registry-iad.fly.io fly auth docker
docker push registry-iad.fly.io/torem-app:latest

We are working to fix the core issue. We'll report back once that's done. In the meantime, we hope the above unblocks deployments.
Posted Sep 04, 2023 - 18:09 UTC
Update
We are continuing to investigate the issue. In the meantime, customers can try deploys using registry2.fly.io.
Posted Sep 04, 2023 - 17:41 UTC
Investigating
Some customers may experience an issue deploying workloads due to failed image pulls
Posted Sep 04, 2023 - 16:36 UTC