Partial Outage in ORD

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 18:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 17:49 UTC

Identified

We've identified the issue as a networking hardware failure impacting a subset of hosts at one of our Upstream providers in ORD. We are working with our provider to restore connectivity.
Posted Jul 03, 2026 - 17:02 UTC

Investigating

We are investigating an issue with one of our upstream providers in ORD. Machines across a subset of hosts may be unreachable or not running correctly. Deploys with machines on these hosts may fail at this time.

Some Managed Postgres clusters in ORD region may be unavailable or see connectivity issues at this time.
Posted Jul 03, 2026 - 17:00 UTC
This incident affected: Managed Postgres (Management Plane - ORD) and Regional Availability (ORD - Chicago, Illinois (US)).