Machines failing to start in DFW

Incident Report for Fly.io

Update

Machine start success rates in DFW have improved but we are continuing to monitor and make further adjustments. We will provide updates as the situation progresses.
Posted Mar 21, 2026 - 08:26 UTC

Update

In addition to freeing up existing capacity, the team has provisioned new capacity in DFW and we are monitoring the results.
Posted Mar 20, 2026 - 12:45 UTC

Monitoring

We freed up some capacity on our workers to allow for successful Machine starts.
Posted Mar 20, 2026 - 08:08 UTC

Investigating

The Machines start failure rate is elevated in DFW.
Posted Mar 20, 2026 - 07:26 UTC
This incident affects: Regional Availability (DFW - Dallas, Texas (US)).