Network issues on newly-created machines

Incident Report for Fly.io

Resolved

This issue is now resolved.
Posted Feb 06, 2026 - 07:07 UTC

Monitoring

We have successfully run a fix to re-sync our global and regional state stores in order to bring machines back to a healthy state, and we're monitoring the situation to confirm that there are no more issues.
Posted Feb 06, 2026 - 02:49 UTC

Identified

Machines created after the delayed machine registration incident (https://status.flyio.net/incidents/3npj6935byt4) may have incomplete networking configurations and could be unable to receive traffic. We've identified the issue and are deploying code fixes as well as updating created machines. This affects a small number of machines on all our regions.
Posted Feb 05, 2026 - 21:52 UTC
This incident affected: Customer Applications.