Issues with deploying apps using Depot builders for new accounts

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 21:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2026 - 21:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 11, 2026 - 20:57 UTC

Investigating

Some new Fly.io users may encounter an "upgrade your organization" error message when attempting to deploy apps for the first time. We're currently working with Depot to figure out what's causing the issue.

In the meantime, you should be able to work around the issue by using Fly builders with `fly deploy --depot=false`.
Posted Feb 11, 2026 - 20:44 UTC
This incident affected: Deployments.