Some Managed Postgres clusters in FRA are unreachable

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 16, 2026 - 15:10 UTC

Monitoring

All affected clusters have recovered
Posted May 16, 2026 - 14:03 UTC

Update

Some of unreachable clusters are showing recovery. We are still fixing the root cause.
Posted May 16, 2026 - 13:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 16, 2026 - 13:22 UTC

Update

We are continuing to investigate this issue.
Posted May 16, 2026 - 12:45 UTC

Investigating

We are currently investigating this issue.
Posted May 16, 2026 - 12:45 UTC
This incident affected: Managed Postgres (Management Plane - FRA).