Edge proxy issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 13:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 12:27 UTC

Investigating

We are investigating increased connection latency and "connection reset" errors from our edge proxy. Apps continue to run, but requests may experience increased connection latency or fail at this time.
Posted Jul 16, 2026 - 11:34 UTC
This incident affected: Customer Applications.