Routing issues in NA regions

Incident Report for Fly.io

Resolved

This incident has been resolved. Due to a BGP issue, we saw some North American traffic routed to edges in Singapore (sin). Users in North America would have seen additional request latency during this period.
Posted Mar 05, 2026 - 19:50 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2026 - 19:38 UTC

Investigating

We're aware of routing issues affecting some customers in North America regions, and we're actively investigating.
Posted Mar 05, 2026 - 19:24 UTC