MPG IAD data plane degraded for new clusters

Incident Report for Fly.io

Resolved

Etcd is stable. Services are back to normal.
Posted Aug 05, 2026 - 20:41 UTC

Identified

High CPU pressure on a shared etcd instance is causing lags on MPG creation in the IAD region
Posted Aug 05, 2026 - 20:26 UTC
This incident affected: Managed Postgres (Management Plane - IAD).