Networking issues in ORD

Incident Report for Fly.io

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2026 - 10:22 UTC

Investigating

We are currently investigating increased latency and dropped connections in ORD (Chicago).
Posted May 29, 2026 - 06:59 UTC
This incident affects: Regional Availability (ORD - Chicago, Illinois (US)).