This incident has been resolved. Networking in IAD has remained stable over the past two hours.
This was caused by a routing issue with an upstream networking provider that impacted connectivity to some hosts in IAD. We applied a change to work around the bad routing, and the underlying issue that caused this in the first place has been identified and fixed.
Posted Jul 11, 2025 - 21:23 UTC
Monitoring
A fix has been applied to all impacted IAD hosts and networking performance in the region has returned to normal.
Fly Managed Postgres clusters in IAD should all now be reachable, as well as Phoenix.new IDEs and preview sites.
We are continuing to closely monitor networking performance in the region to ensure stability and full recovery.
Posted Jul 11, 2025 - 19:18 UTC
Update
We are continuing to work on implementing the fix to the impacted hosts in IAD.
Posted Jul 11, 2025 - 18:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 11, 2025 - 18:25 UTC
Update
We are continuing to investigate this issue. Connectivity between a number of hosts in the IAD region is degraded.
Customers will see inbound and outbound issues connecting to and from machines on impacted hosts.
Some Fly Managed Postgres clusters are impacted by this, users may see additional latency or failures connecting to clusters in IAD.
Some users will see 500 errors accessing Phoenix.new IDEs and preview sites at this time.
Posted Jul 11, 2025 - 18:13 UTC
Investigating
We are currently investigating networking issues in IAD. Customers may see higher latency and elevated packet loss connecting to machines in this region.
Posted Jul 11, 2025 - 18:06 UTC
This incident affected: Managed Postgres (Management Plane - IAD), Regional Availability (IAD - Ashburn, Virginia (US)), and Phoenix.new.