Most queued historical logs have been ingested and should now be available through log search. Log ingestion rates have returned to normal levels.
Posted Jun 19, 2026 - 21:53 UTC
Monitoring
We've applied a fix for this issue. Historical logs are currently backfilling. We will post an update once logs have finished backfilling and current logs are being ingested normally.
Posted Jun 19, 2026 - 18:19 UTC
Update
Log search is available; however, new app logs since ~1 hour ago are missing and new logs are not being ingested. We are continuing to investigate.
Posted Jun 19, 2026 - 18:10 UTC
Investigating
We are investigating an issue causing application log search to be unavailable. This is affecting the Fly Metrics log search panels, and historical application logs initially returned from the `fly logs` command.
Streaming logs using `fly logs`, the Live Logs page in the dashboard, and Fly Log Shipper services continue to work as expected.