Blocked Apps V1 deployments

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 29, 2023 - 05:41 UTC

Monitoring

We are monitoring the recovery of AppV1/Nomad deployments.
Posted Mar 29, 2023 - 03:48 UTC

Update

Vault and AppV1/Nomad deploys are recovering. We are continuing with additional repair work.
Posted Mar 29, 2023 - 03:29 UTC

Identified

We have isolated the AppsV1 deployment problems to failures interacting with Vault and are working to mitigate further issues.
Posted Mar 29, 2023 - 02:52 UTC

Investigating

AppsV1/Nomad deploys have been re-enabled.

We continue to investigate a subset of customer apps that remain unable to schedule deploys.
Posted Mar 28, 2023 - 20:47 UTC

Update

We have identified an issue that resulted in selected AppsV1 deployments failing to be properly scheduled.

Deployments of AppsV1 continue to be blocked while we isolate the issue.
Posted Mar 28, 2023 - 20:18 UTC

Update

Deploys and application scaling have been paused while we continue to work to resolve the issue.
Posted Mar 28, 2023 - 18:28 UTC

Identified

Issues with Routing and DNS have been mitigated. Deploys for AppsV1 continue to be impacted.
Posted Mar 28, 2023 - 17:35 UTC

Investigating

We are investigating failure reports of DNS and proxy routing. Deploys are impacted as well.

Routing to Machines is not believed to be impacted.
Posted Mar 28, 2023 - 17:19 UTC