API issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 18:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 17:24 UTC

Identified

We have identified an issue with our GraphQL API server and are working to resolve this issue. Most Machines API endpoints are functioning at this time. Creating new machines/volumes, as well as updating machines, will still fail.
Posted Aug 19, 2025 - 17:03 UTC

Investigating

We are investigating an issue with our primary database. Machines API and GraphQL calls may fail at this time, and the dashboard may be unavailable. Apps continue to run.
Posted Aug 19, 2025 - 16:51 UTC
This incident affected: Dashboard and Machines API.