Fly ssh console command failing

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 14:18 UTC

Monitoring

A fix has been implemented and we are seeing `ssh console` commands succeed as normal.
Posted Mar 18, 2026 - 14:17 UTC

Identified

We have identified an issue causing new `fly ssh console` connections to fail with 500 errors. A fix is in progress.
Posted Mar 18, 2026 - 14:12 UTC
This incident affected: Machines API.