flyctl deploy creating new app instances

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 00:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 00:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2026 - 00:07 UTC

Investigating

We're investigating an issue where fly deploy is creating new Fly machine instances rather than updating existing ones, leading to apps with a mixed state. We're currently investigating the issue.

As a workaround, please try removing the "processes = [ "app" ]" line from your fly.toml configuration file and redeploying. Another workaround is to downgrade flyctl to 0.4.40 - this should resolve the issue in the meantime.
Posted Apr 28, 2026 - 23:50 UTC
This incident affected: Deployments.