Proxy issues in SIN region

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted May 19, 2026 - 12:00 UTC

Monitoring

A fix has been implemented and we are seeing proxy performance in SIN return to normal. All Managed Postgres clusters in the region are reachable. We are continuing to monitor to ensure stable recovery.
Posted May 19, 2026 - 11:22 UTC

Investigating

We are investigating issues with fly-proxy on a subset of hosts in the Singapore region. Apps are still running, but requests to/from some apps may fail, and some Managed Postgres clusters may be inaccessible.
Posted May 19, 2026 - 11:15 UTC
This incident affected: Managed Postgres (Management Plane - SIN) and Regional Availability (SIN - Singapore).