General Network Issues with IPv6

Incident Report for Fly.io

Resolved

This incident has been resolved. It was caused by a recent `flyctl` update and only apps deployed with flyctl version v0.3.227 were affected. We have deployed a server-side workaround.
Posted Nov 29, 2025 - 18:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2025 - 17:52 UTC

Update

We will be rolling out a fix shortly
Posted Nov 29, 2025 - 17:44 UTC

Identified

We have identified an issue affecting newly-allocated Anycast ingress IPv6 addresses for some apps and are working to deploy a fix. These apps may experience timeouts when connecting over IPv6 (which some clients default to).
Posted Nov 29, 2025 - 17:32 UTC

Investigating

We are currently investigating issues with some apps on IPv6.
Posted Nov 29, 2025 - 17:20 UTC
This incident affected: Customer Applications.