Networking performance degraded in BOM and SJC

Incident Report for Fly.io

Monitoring

Network performance has been restored and we're continuing to monitor.
Posted May 23, 2026 - 02:14 UTC

Investigating

We're currently looking into this issue.
Posted May 23, 2026 - 01:01 UTC
This incident affects: Regional Availability (BOM - Mumbai, India, SJC - San Jose, California (US)).