AMS network issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 15:58 UTC

Monitoring

A fix has been implemented on all hosts in AMS and we are seeing networking return to normal in the region. We are continuing to monitor networking in the region to ensure stability.
Posted Jul 24, 2025 - 15:35 UTC

Identified

The issue has been identified and an initial fix has been deployed. We are seeing improvements on most hosts in the region, and are continuing to work on restoring the remaining impacted hosts.
Apps with machines on impacted hosts may still experience network issues at this time.
Posted Jul 24, 2025 - 15:13 UTC

Investigating

We are investigating upstream network issues in AMS region. Apps may experience network issues.
Posted Jul 24, 2025 - 14:45 UTC
This incident affected: Regional Availability (AMS - Amsterdam, Netherlands).