"unauthorized" errors when starting some Fly builds

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 00:27 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 00:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 15, 2025 - 00:05 UTC

Update

We're continuing to investigate the issue. Both legacy Fly builders and Buildkit builders are affected by this - if you're running into this error, please try deploying with `--depot=true`. (The default `fly deploy` and `fly launch` use Depot builders, which remain unaffected by this issue.)
Posted Oct 14, 2025 - 23:34 UTC

Investigating

We're investigating reports of "unauthorized" errors when doing `fly deploy` operations using the `--depot=false` parameter. This is not enabled by default, and Depot builders are unaffected. If you're seeing this error, try deploying with `--depot=true` to work around problems with legacy Fly builders.
Posted Oct 14, 2025 - 22:19 UTC
This incident affected: Deployments and Remote Builds.