SIN, NRT network issues

Incident Report for Fly.io

Identified

We are continuing to experience network issues with an upstream provider in SIN and NRT regions.
Posted Jun 22, 2026 - 18:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 17:44 UTC

Identified

Our upstream provider has identified the issue and is working on a fix. Apps running in NRT (Tokyo) region may also have issues reaching certain destinations at this time.
Posted Jun 22, 2026 - 17:24 UTC

Investigating

We are investigating an upstream network issue in the SIN (Singapore) region. Apps may be unreachable or have higher packet loss.
Posted Jun 22, 2026 - 17:10 UTC
This incident affects: Regional Availability (NRT - Tokyo, Japan, SIN - Singapore).