Errors issuing new SSL certificates

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 23:18 UTC

Monitoring

A fix has been implemented upstream and certificates are being issued successfully. We will continue to monitor.
Posted Jul 02, 2026 - 22:50 UTC

Identified

The issue has been identified and we are awaiting a fix.
Posted Jul 02, 2026 - 22:26 UTC

Investigating

We are currently investigating errors when issuing new SSL certificates for hostnames.
Posted Jul 02, 2026 - 21:38 UTC
This incident affected: SSL/TLS Certificate Provisioning.