Deployment issues
Incident Report for Fly.io
Resolved
This incident has been resolved.
Posted Jun 02, 2022 - 13:57 CDT
Update
We are continuing to monitor for any further issues.
Posted Jun 02, 2022 - 13:12 CDT
Monitoring
We restored the Consul cluster and are monitoring individual services. Most service is restored, but some lingering issues may persist.
Posted Jun 02, 2022 - 12:30 CDT
Identified
Our Consul servers are in out-of-memory loops. We are working to recover them. Consul issues can cause problems with internal DNS resolution, deploys, and API access. We are working to recover the servers.
Posted Jun 02, 2022 - 12:19 CDT
Investigating
Our internal server-orchestration cluster is suffering from capacity issues, causing deployment operations to be unavailable.
Posted Jun 02, 2022 - 12:08 CDT
This incident affected: Platform and Tools (API, Deployments, Dashboard) and Application Hosting (Private DNS).