Metrics are degraded

Incident Report for Fly.io

Resolved

Metrics processing has caught up, and we don't see any data loss.
Posted Feb 24, 2026 - 11:06 UTC

Update

Delayed metrics are still being processed.
Posted Feb 24, 2026 - 09:35 UTC

Monitoring

Metrics are coming back online, but it will take a little time to process what's backed up in the queues.
Posted Feb 24, 2026 - 06:46 UTC

Update

We're continuing to work with VictoriaMetrics support on a fix for this issue.
Posted Feb 24, 2026 - 05:49 UTC

Identified

In some cases data is missing or lagging. We've identified the problem and are working on a fix.
Posted Feb 24, 2026 - 04:33 UTC
This incident affected: Metrics.