Some billing operations failing to synchronize

Incident Report for Fly.io

Resolved

Everything is working normally and billing tasks have run to completion and stabilized.
Posted Sep 12, 2025 - 15:52 UTC

Monitoring

We've fixed the issue and are monitoring normalization while DNS records propagate and pending processes run to completion.
Posted Sep 12, 2025 - 14:26 UTC

Identified

Due to a DNS issue (it's always DNS, isn't it?), some billing-related operations are going unprocessed. This affects mainly registration of payment methods. Usage metering is not affected.
Posted Sep 12, 2025 - 14:18 UTC