Fly.io APIs and dashboard inaccessible

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 18:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 17:50 UTC

Investigating

Trying to log into Fly.io dashboard, most `flyctl` commands and API requests are returning HTTP 503 errors. We are investigating.
Posted Jul 29, 2025 - 17:39 UTC
This incident affected: Dashboard, Machines API, and Deployments.