Upstash Redis Connectivity issues in IAD
Incident Report for Fly.io
Resolved
This issue has been resolved.
Posted Jul 03, 2024 - 23:55 UTC
Update
The host has been brought back online and work is being done to restore the Upstash Redis Cluster in IAD.
Posted Jul 03, 2024 - 22:32 UTC
Update
Some existing Upstash Redis databases in the IAD region are still experiencing connection issues. We are continuing to work on restoring the impacted host to restore these.
The ability to create new Upstash Redis databases in the IAD has been restored. Newly created databases are not impacted by the current issue.
Posted Jul 03, 2024 - 19:24 UTC
Identified
We have identified the cause of the issues to a host hardware failure that is impacting the Upstash Redis cluster. We are working to restore the failed hardware.

Upstash Redis Databases with primaries in regions other than IAD are not impacted.
Posted Jul 03, 2024 - 16:16 UTC
Update
We are continuing to investigate this issue.
Posted Jul 03, 2024 - 15:58 UTC
Investigating
We are investigating customer issues connecting to Upstash Redis primaries in the IAD region
Posted Jul 03, 2024 - 15:57 UTC