Global network issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 07:30 UTC

Monitoring

We're seeing networking latency and packet loss return to normal across all regions. We are continuing to monitor.
Posted Oct 31, 2025 - 07:20 UTC

Update

We're seeing improvements to latency and packet loss across all regions. We're continuing to work with our upstream providers.
Posted Oct 31, 2025 - 07:07 UTC

Update

Our upstream providers have identified the issue and are working on mitigations.
Posted Oct 31, 2025 - 06:50 UTC

Identified

We are working with our upstream providers to resolve this issue.
Posted Oct 31, 2025 - 06:30 UTC

Investigating

We are investigating network issues between various regions. Machines may experience increased latency or packet loss. Machines API requests may occasionally fail.
Posted Oct 31, 2025 - 06:14 UTC
This incident affected: Machines API.