Elevated API Latency and Timeout Errors
Incident Report for Fly.io
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 23:25 UTC
Monitoring
A fix has been implemented and both Machines API and GraphQL API performance have returned to normal.
Posted Nov 26, 2024 - 21:13 UTC
Identified
We have identified the cause of the API latency increase and are working to mitigate
Posted Nov 26, 2024 - 20:28 UTC
Investigating
We are currently investigating elevated error rates with our Machines and Graphql APIs.

Users may experience slower responses or timeouts using the Machines API and flyctl commands
Posted Nov 26, 2024 - 20:23 UTC
This incident affected: Machines API.