Upstream network issues

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 15:57 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 15:33 UTC

Update

We're updating the affected region list to also include SJC since this seems to be a wider upstream issue in US West Coast.
Posted Sep 02, 2026 - 14:56 UTC

Update

We have put in some temporary mitigations along with our providers. However since the root cause of this issue lies within a bigger upstream transit provider, you may continue to see some elevated latency and connection issues in/around affected regions. We're still working closely with them to resolve the root cause.
Posted Sep 02, 2026 - 14:48 UTC

Identified

We have observed an upstream network issue in LAX. Connections to some destinations may see elevated latency and packet loss. We're working with our upstream to resolve this issue.
Posted Sep 02, 2026 - 14:18 UTC
This incident affected: Regional Availability (LAX - Los Angeles, California (US), SJC - San Jose, California (US)).