UDP Routing Issue On New Servers
Incident Report for Fly.io
Resolved
This incident has been resolved.
Posted May 20, 2022 - 10:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2022 - 22:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 19, 2022 - 22:24 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 19, 2022 - 22:21 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 19, 2022 - 22:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 19, 2022 - 22:18 UTC
Identified
Some new servers we're deploying in these regions have broken UDP routing (they have a newer kernel, and were deployed with an incompatible version of our XDP routing code). We're fixing these and will update as we go. (If your UDP-using application was working before, it should still be working now, but if you deploy into one of these regions right now you might land on a broken server while we address this).
Posted May 19, 2022 - 22:07 UTC
This incident affected: Regional Availability (AMS - Amsterdam, Netherlands, LAX - Los Angeles, California (US), NRT - Tokyo, Japan, SEA - Seattle, Washington (US), SIN - Singapore, SJC - Sunnyvale, California (US)).