Oauth/Macaroon Errors from flyctl

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Aug 20, 2026 - 14:16 UTC

Monitoring

A fix has been deployed and this error should no longer be occurring. We're monitoring to ensure full recovery.
Posted Aug 20, 2026 - 14:05 UTC

Identified

We have identified an issue causing authentication errors for some operations from `flyctl`. These operations are failing with an error like: `This endpoint no longer accepts legacy OAuth tokens (starting with `fo1_`). Please use a macaroon token (starting with `fm2_`) instead.

We have identified the issue and are rolling out a fix
Posted Aug 20, 2026 - 13:54 UTC