Managed Postgres - Connectivity errors in IAD

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 10:49 UTC

Monitoring

We've implemented a fix and are seeing the number of connection errors decrease. We're continuing to monitor to ensure full recovery.
Posted Jul 02, 2025 - 10:37 UTC

Investigating

We are currently investigating elevated connectivity errors between our control plane and a small number of Managed Postgres clusters in IAD.
Posted Jul 02, 2025 - 09:47 UTC
This incident affected: Managed Postgres (Management Plane - IAD).