SSH failing for newly created machines

Incident Report for Fly.io

Resolved

This incident has been resolved.
Posted Feb 10, 2025 - 22:53 UTC

Monitoring

This issue has been fixed, newly created machines will have working SSH.

Machines created during this incident will need to be updated (`fly machine update --yes `) or deleted/recreated to fix SSH.
Posted Feb 10, 2025 - 21:59 UTC

Update

As a workaround, run the `fly ssh console` command with `--pty --command /bin/sh` flags.
Posted Feb 10, 2025 - 21:47 UTC

Investigating

We are investigating reports that connecting to newly created machines via SSH (`fly ssh console`) may fail.
Posted Feb 10, 2025 - 21:39 UTC